View Issue Details

IDProjectCategoryView StatusLast Update
0000052NewsStatsTabulationpublic2013-09-02 14:52
ReporterthhAssigned Tothh 
PriorityurgentSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
ProjectionnoneETAnone 
Product VersionProduct Build 
Target Version0.01Fixed in Version0.01 
Summary0000052: gatherstats crashes
DescriptionUndefined subroutine &main::ParseHierarchies called at ./gatherstats.pl line 149.
Steps To ReproduceRun gatherstats
TagsNo tags attached.

Relationships

related to 0000049 resolvedthh "Virtual" .ALL groups are missing if every group in that hierarchy has 0 postings 

Activities

thh

thh

2013-09-01 17:21

administrator   ~0000051

Last edited: 2013-09-01 17:21

View 2 revisions

Was added with commit b5125b1099cf5cf12beb0520d5896b9a1d7850ae while fixing 0000049.

ParseHierarchies must be ex- and imported.

thh

thh

2013-09-02 06:58

administrator   ~0000052

Fix committed to next branch as 1703b8e3b454713d4f873acdb5cb400db490a152: Get empty 'virtual' hierarchies working.

Commit b5125b1099cf5cf12beb0520d5896b9a1d7850ae
was broken.

We didn't add empty .ALL hierarchies as needed;
we added empty (non-existant) hierarchies without
appended '.ALL', and didn't add the original
empty group we started with.

(What's more, gatherstats didn't even start any
more due to missing ex- and import of
&ParseHierarchies from NewsStats.pm.)

Fixes 0000052 (and some more breakage).

Signed-off-by: Thomas Hochstein <thh@inter.net>

Related Changesets

NewsStats: next 1703b8e3

2013-09-01 15:52:21

thh

Details Diff
Get empty 'virtual' hierarchies working.

Commit b5125b1099cf5cf12beb0520d5896b9a1d7850ae
was broken.

We didn't add empty .ALL hierarchies as needed;
we added empty (non-existant) hierarchies without
appended '.ALL', and didn't add the original
empty group we started with.

(What's more, gatherstats didn't even start any
more due to missing ex- and import of
&ParseHierarchies from NewsStats.pm.)

Fixes 0000052 (and some more breakage).

Signed-off-by: Thomas Hochstein <thh@inter.net>
mod - gatherstats.pl Diff File
mod - NewsStats.pm Diff File

Issue History

Date Modified Username Field Change
2013-09-01 17:20 thh New Issue
2013-09-01 17:20 thh Status new => assigned
2013-09-01 17:20 thh Assigned To => thh
2013-09-01 17:20 thh Relationship added related to 0000049
2013-09-01 17:21 thh Note Added: 0000051
2013-09-01 17:21 thh Note Edited: 0000051 View Revisions
2013-09-02 06:58 thh Changeset attached => NewsStats next 1703b8e3
2013-09-02 06:58 thh Note Added: 0000052
2013-09-02 06:58 thh Status assigned => resolved
2013-09-02 06:58 thh Resolution open => fixed
2013-09-02 14:52 thh Fixed in Version => 0.01